s390 architecture · Supported
Maintainers
- M Heiko Carstens <hca@linux.ibm.com>
- M Vasily Gorbik <gor@linux.ibm.com>
- M Alexander Gordeev <agordeev@linux.ibm.com>
- R Christian Borntraeger <borntraeger@linux.ibm.com>
- R Sven Schnelle <svens@linux.ibm.com>
Paths
- F
Documentation/driver-api/s390-drivers.rst - F
Documentation/arch/s390/ - F
arch/s390/ - F
drivers/s390/ - F
drivers/watchdog/diag288_wdt.c
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-security-module (capped at 30), ordered by date desc.
-
COLD22d
[PATCH 09/11] treewide: Convert custom kernel_param_ops .get callbacks to seq_buf via cocci
2026-05-21 · Kees Cook <kees@kernel.org> -
COLD22d
[PATCH 04/11] treewide: Convert struct kernel_param_ops initializers to DEFINE_KERNEL_PARAM_OPS
2026-05-21 · Kees Cook <kees@kernel.org> -
STALE77d
[PATCH 43/61] s390: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden> -
STALE111d
[PATCH] integrity: Eliminate weak definition of arch_get_secureboot()
2026-03-09 · Nathan Chancellor <nathan@kernel.org> -
STALE115d
Re: [PATCH] integrity: avoid using __weak functions
2026-03-06 · Nathan Chancellor <nathan@kernel.org> -
STALE115d
[PATCH] integrity: avoid using __weak functions
2026-03-06 · Arnd Bergmann <arnd@kernel.org> -
STALE118d
[PATCH 1/1] s390/ipl: Fix missing arch_get_secureboot() prototype warning
2026-03-05 · Vasily Gorbik <gor@linux.ibm.com> -
STALE98d
REVIEWED: 1 (1M) [PATCH v3 4/8] module: Give MODULE_SIG_STRING a more descriptive name
2026-03-05 · Thomas Weißschuh <hidden> -
STALE98d
REVIEWED: 1 (1M) [PATCH v3 3/8] module: Give 'enum pkey_id_type' a more specific name
2026-03-05 · Thomas Weißschuh <hidden> -
STALE119d
REVIEWED: 1 (1M) [PATCH v2 4/8] module: Give MODULE_SIG_STRING a more descriptive name
2026-03-05 · Thomas Weißschuh <hidden> -
STALE119d
REVIEWED: 1 (1M) [PATCH v2 3/8] module: Give 'enum pkey_id_type' a more specific name
2026-03-05 · Thomas Weißschuh <hidden> -
STALE120d
[PATCH 4/8] module: Give MODULE_SIG_STRING a more descriptive name
2026-03-02 · Thomas Weißschuh <hidden> -
STALE120d
[PATCH 3/8] module: Give 'enum pkey_id_type' a more specific name
2026-03-02 · Thomas Weißschuh <hidden> -
STALE118d
[PATCH v3 1/3] integrity: Make arch_ima_get_secureboot integrity-wide
2026-02-13 · Coiby Xu <hidden> -
STALE133d
Re: [PATCH 3/5] mm: export zap_page_range_single and list_lru_add/del
2026-02-05 · "David Hildenbrand (arm)" <david@kernel.org> -
STALE133d
Re: [PATCH 3/5] mm: export zap_page_range_single and list_lru_add/del
2026-02-05 · "David Hildenbrand (arm)" <david@kernel.org> -
STALE140d
[PATCH v2 1/3] integrity: Make arch_ima_get_secureboot integrity-wide
2026-02-03 · Coiby Xu <hidden> -
STALE126d
[PATCH 1/3] integrity: Make arch_ima_get_secureboot integrity-wide
2026-01-15 · Coiby Xu <hidden> -
STALE240d
[PATCH v6 1/5] Wire up lsm_config_self_policy and lsm_config_system_policy syscalls
2025-10-10 · Maxime Bélair <hidden> -
STALE63d
[PATCH v3 05/14] s390/pkey: Remove redundant rcu_read_lock/unlock() in spin_lock
2025-09-16 · pengdonglin <hidden> -
STALE289d
[PATCH v2] rcu: Remove redundant rcu_read_lock/unlock() in spin_lock critical sections
2025-09-15 · pengdonglin <hidden> -
STALE291d
[PATCH] rcu: Remove redundant rcu_read_lock/unlock() in spin_lock critical sections
2025-09-12 · pengdonglin <hidden> -
STALE287d
LANDED [PATCH v2 3/4] arch: copy_thread: pass clone_flags as u64
2025-09-01 · Simon Schuster via B4 Relay <devnull+schuster.simon.siemens-energy.com@kernel.org> -
STALE326d
LANDED: 2 (2M) [PATCH v3 07/13] s390: Handle KCOV __init vs inline mismatches
2025-07-17 · Kees Cook <kees@kernel.org> -
STALE326d
LANDED [PATCH v3 01/13] stackleak: Rename STACKLEAK to KSTACK_ERASE
2025-07-17 · Kees Cook <kees@kernel.org> -
STALE265d
[PATCH v5 1/3] Wire up lsm_config_self_policy and lsm_config_system_policy syscalls
2025-07-09 · Maxime Bélair <hidden> -
STALE366d
[PATCH v4 1/3] Wire up lsm_config_self_policy and lsm_config_system_policy syscalls
2025-07-01 · Maxime Bélair <hidden> -
STALE366d
[PATCH v3 1/3] Wire up lsm_config_self_policy and lsm_config_system_policy syscalls
2025-06-24 · Maxime Bélair <hidden> -
STALE377d
[PATCH v2 1/3] Wire up lsm_config_self_policy and lsm_config_system_policy syscalls
2025-06-19 · Maxime Bélair <hidden> -
STALE358d
[PATCH v2 07/14] s390: Handle KCOV __init vs inline mismatches
2025-05-23 · Kees Cook <kees@kernel.org>
Needs attention (review trailers in, no pickup)
Patches with review trailers that haven't landed in mainline and haven't been Acked by a maintainer. Oldest first.
-
STALE119d
REVIEWED: 1 (1M) [PATCH v2 3/8] module: Give 'enum pkey_id_type' a more specific name
2026-03-05 · Thomas Weißschuh <hidden> · 1 Reviewed-by -
STALE119d
REVIEWED: 1 (1M) [PATCH v2 4/8] module: Give MODULE_SIG_STRING a more descriptive name
2026-03-05 · Thomas Weißschuh <hidden> · 1 Reviewed-by -
STALE98d
REVIEWED: 1 (1M) [PATCH v3 3/8] module: Give 'enum pkey_id_type' a more specific name
2026-03-05 · Thomas Weißschuh <hidden> · 1 Reviewed-by -
STALE98d
REVIEWED: 1 (1M) [PATCH v3 4/8] module: Give MODULE_SIG_STRING a more descriptive name
2026-03-05 · Thomas Weißschuh <hidden> · 1 Reviewed-by
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE120d
[PATCH 3/8] module: Give 'enum pkey_id_type' a more specific name
2026-03-02 · Thomas Weißschuh <hidden> -
STALE120d
[PATCH 4/8] module: Give MODULE_SIG_STRING a more descriptive name
2026-03-02 · Thomas Weißschuh <hidden> -
STALE77d
[PATCH 43/61] s390: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden>